2019. augusztus 17., szombat

Gyorskeresés

Mikrotik router programozás: Dual WAN failover + forwarding mindkét wan-on

Írta: |

[ ÚJ BEJEGYZÉS ]

Ez egy egyszerű megoldás mikrotikra két internet autómata át és visszakapcsolással valamint külön wanonként tűzfalszabályokkal. Feltételezi a mikrotik eszközök alapvető programozását.
Ezt a bejegyzést leginkább magamnak írtam jegyzetnek, szabadon felhasználható.

Interfészek nevei WAN1 és WAN2 értelem szerűen ezek bejövő internet portok nevei
LAN pedig a helyi bridge neve!

Eddig fix ip-s internettel próbáltam le biztosan, ezért az address-t meg kell adni a wan1 és wan2 portoknak. Forgalmat mindkettő bonyolít majd, de kifele internetezni alapesetben csak a wan1-esen lehet majd.

maszkolás a két internetfelől

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

majd kézzel hozzáadjuk az internetszolgáltatók gatewayeit, ez esetben a nagyobb distance-vel rendelkező kapcsolat lesz a másodlagos.

/ip route
add dst-address=0.0.0.0/0 gateway=egyikgateway distance=1
add dst-address=0.0.0.0/0 gateway=másikgateway distance=2

példának ugyan úgy engedünk ki tűzfalon dolgokat mint egy wan esetén csak itt két irányba is megtehetjük külön külön

/ip firewall nat
add chain=dstnat action=dst-nat in-interface=WAN1 dst-port=80 to-address=szerveripegyik
add chain=dstnat action=dst-nat in-interface=WAN2 dst-port=80 to-address=szerveripmásik

Eddig annyi fog működni hogy a mikink átkapcsol ha kell de nem fogja fentartani a wan2 kapcsolatot mert az "messzebb van" és nem küld oda csomagokat, zárva tartja.

Ekkor jön a prerouting:

/ip firewall mangle
add chain=prerouting in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_connection
add chain=prerouting in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_connection

/ip firewall mangle
add chain=prerouting in-interface=LAN connection-mark=WAN1_connection action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting in-interface=LAN connection-mark=WAN2_connection action=mark-routing new-routing-mark=to_WAN2

/ip route
add dst-address=0.0.0.0/0 routing-mark=to_WAN1 gateway=egyikgateway
add dst-address=0.0.0.0/0 routing-mark=to_WAN2 gateway=másikgateway

Ezzel a route résznél lesz összesen 4db 0.0.0.0 szabályunk. És minden forgalom ami a wan2-nél bejön az oda is kerül attól függetlenül hogy a routenál kifele a distance nagyobb mint a wan1 esetén.

Copyright © 2000-2019 PROHARDVER Informatikai Kft.