2021. május 13., csütörtök

Gyorskeresés

TP-Link 941ND router abúzus :D

Írta: | Kulcsszavak: router . flash . openwrt . tp-link . gányolás

[ ÚJ BEJEGYZÉS ]

Érkezett pár döglött router, van mivel szórakozni... A legígéretesebb egy TL-WR941 volt, amit a tulaj állítólag elflashelt. Eléggé elflashelhette, mert a flash IC teljesen döglött volt. Bekapcsolásra az eszközön egy darab LED világított, se előre, se hátra. Soros porton meg sem szólalt. Szóval nekromancia, és az élőhalott meggyalázása következett... ;]

Leszedtem a flasht (Spansion S25FL032 volt rajta, 4MB), és megpróbáltam kiolvasni (CH341G alapú kínai kókány EEPROM/SPI flasher). Semmi. Döglött.

Na de mi kerüljön a helyére? Ugyanabban a csomagban volt egy 1043v3 is, a "melegszik a SoC mintha muszáj lenne" hibával (ez helyből kuka), azon van egy Winbond W25Q64 (ha átnéztem volna a félvezetőimet, biztos lett volt megfelelőbb is). Az meg 8MB-os, viszont működött.

Ó, flash upgrade is lesz :D Mint itt! A gyári szoftver is bebootol nagyobb flash-el, a cél meg úgyis valami egyéb volt.

Előre gondolkodva, szépen bedrótoztam a flash chip-et az alaplapra. Csatlakozóval, hogy könnyebb legyen átdugdozni az íróra, ha nem bootol :DDD Kellett is... (És innentől köszi az OpenWRT topic segítségét is!)

Persze a gyári fw-t felírva nem csinált semmit, mert annak az elején van egy signature, amit le kéne vágni. 941-ről meg alig van valami infó, pláne erről az 5.1-es verzióról, ami még az 5.0-val sem teljesen azonos (tök mindegy, a gyárinak levágtam az elejéről annyit, amennyit elvileg kell, és semmi :S ). A 841nd v8-al viszont azonos! (Sőt! A 940v2 meg mind a kettővel azonos... :DDD :F )

A fentebb linkelt OpenWRT fórumos postban viszont van egy extrázott U-bot loader, ami 841-hez jó, és a postolónak is működött 941-en. Az bebootolt!


Ez az író, meg a flash egy adapterkártyán

Valahogy így kell felírni egy CH341-es íróval :
dd if=/dev/zero bs=1M count=8 of=padded.bin #készítünk egy padded.bin nevű, 8MB-os üres file-t
dd if=modded_u_boot.bin conv=notrunc of=padded.bin #a mod bootolader megy az üres file elejére
sudo flashrom --programmer ch341a_spi -w padded.bin #a flashrom parancs beleírja a file-t a flashbe

Kisebb/nagyobb flashbe ugyanígy megy, csak megfelelő méretű file-t kell létrehozni. A flashrom ugyanis csak akkorát hajlandó felírni, amekkora a cél mérete. Nyilván így csak egy botloader lesz az egészen, de már lehet tudni, hogy bootol-e, mert az U-boot felvillantja a LED-eket egyből indulás után, ahogyan azt kb. minden gyári szoftveres TP-Link router is teszi. Meg hát látszik a soroson is.

Lehet backupot is csinálni a flash tartalmáról, a
sudo flashrom --programmer ch341a_spi -r backup.bin
paranccsal.


Fércmunka :D A kis zöld NYÁK az előbbi adapter, az USB-n jobbra meg a soros illesztő lóg


Még jó, hogy kivezettem :D

A moddolt U-bootban van egy webszerver image feltöltéshez (128kB-os cuccról beszélünk...), és egy rakás paranccsal többet ismer soros porton is. Az U-boot-ból visszaírtam a router MAC címét is. (Setmac parancs lentebb, ez leteszi a flashbe is a MAC-et.) Ha nem moddolt U-boottal indítjuk a routert, akkor pl. a TFTP-s folyamattal lehet feltenni szoftvert.

Innentől kezdve már csak fel kellett tölteni egy OpenWRT sysupgrade imaget, és már bootolt is. Így :

***************************************
* U-Boot 1.1.4-7a540a78-clean *
* Build: 2018-02-23 *
***************************************

** Warning: bad env CRC, using default,
use 'saveenv' to save it in FLASH

BOARD: TP-Link TL-WR841N/D v8
SOC: AR9341 rev. 3
CPU: MIPS 74Kc
RAM: 32 MB DDR1 16-bit CL3-3-3-8
FLASH: 8 MB Winbond W25Q64
MAC: 00:00:00:00:00:00
CLOCKS: CPU/RAM/AHB/SPI/REF
550/400/200/ 25/ 25 MHz

Hit any key to stop booting: 1 0

Booting image from 0x9F020000...
## Error: unsupported image header

## Error: failed to execute 'bootcmd'!
Starting web server for update...

Link down: eth0
Link down: eth1
Link down: eth0
Link down: eth1
Link down: eth0
Link down: eth1
Link down: eth0
Link down: eth1
Link down: eth0
Link down: eth1
Link down: eth0
Link down: eth1
Link down: eth0
Link down: eth1
Link down: eth0
Link down: eth1
Link down: eth0
Link down: eth1
Link down: eth0
Link down: eth1
## Error: couldn't initialize eth (cable disconnected?)!

u-boot> printenv

bootargs=console=ttyS0,115200 root=31:02 rootfstype=squashfs init=/sbin/init mtdparts=ath-nor0:128k(u-boot),1024k(kernel),2816k(rootfs),64k(config),64k(art)
bootcmd=bootm 0x9F020000
bootdelay=1
baudrate=115200
ipaddr=192.168.1.1
serverip=192.168.1.2
autoload=no
hostname=u-boot_tl-wr841nd-v8
bootfile=firmware.bin
loadaddr=0x80800000
ncport=6666
lsdk_kernel=1
uboot_name=u-boot.bin
uboot_addr=0x9F000000
uboot_size=0x1EC00
uboot_upg=if ping $serverip; then tftpb $loadaddr $uboot_name && if itest.l $filesize <= $uboot_size; then erase $uboot_addr +$uboot_size && cp.b $loadaddr $uboot_addr $uboot_size && echo DONE! U-Boot upgraded!; else echo ERROR! File is too big!; fi; else echo ERROR! $serverip is not reachable!; fi
fw_addr=0x9F020000
fw_upg=if ping $serverip; then tftpb $loadaddr $bootfile && erase $fw_addr +$filesize && cp.b $loadaddr $fw_addr $filesize && echo DONE! Firmware upgraded!; else echo ERROR! $serverip is not reachable!; fi
recovery=if button; then sleep 600;setenv cnt 0;setenv stop_boot;echo Keep button pressed for at least:;echo - 3s for web based recovery;echo - 5s for U-Boot console;echo - 7s for network console;echo;while button && itest $cnt < 0xA; do ledon;sleep 300;echo . '\\c';sleep 300;ledoff;sleep 600;setexpr cnt $cnt + 1;done;echo 0x$cnt seconds;echo;if itest $cnt >= 0xA; then echo \#\# Error: 10s limit reached!;echo Continuing normal boot...;echo;elif itest $cnt >= 7; then echo Starting network console...;setenv stop_boot 1;echo;startnc;elif itest $cnt >= 5; then echo Starting U-Boot console...;setenv stop_boot 1;echo;elif itest $cnt >= 3; then echo HTTP server is starting for firmware update...;setenv stop_boot 1;echo;httpd;elif itest $cnt < 3; then echo \#\# Error: button was not pressed long enough!;echo Continuing normal boot...;echo;fi;setenv cnt;fi
stdin=serial
stdout=serial
stderr=serial
ethaddr=00:00:00:00:00:00
ethact=eth0

Environment size: 1887/4092 bytes

u-boot> setenv ethaddr c0:4a:00:b8:27:8c

u-boot> setmac c0:4a:00:b8:27:8c

(Itt elindítottam a webszerverről az image feltöltését - elsőre nem is sikerült neki)

***************************************
* U-Boot 1.1.4-7a540a78-clean *
* Build: 2018-02-23 *
***************************************

** Warning: bad env CRC, using default,
use 'saveenv' to save it in FLASH

BOARD: TP-Link TL-WR841N/D v8
SOC: AR9341 rev. 3
CPU: MIPS 74Kc
RAM: 32 MB DDR1 16-bit CL3-3-3-8
FLASH: 8 MB Winbond W25Q64
MAC: C0:4A:00:B8:27:8C
CLOCKS: CPU/RAM/AHB/SPI/REF
550/400/200/ 25/ 25 MHz

Hit any key to stop booting: 1 0

Booting image from 0x9F020000...

Vendor/image name: OpenWrt r7989-82fbd85747
Hardware ID: 0x9410005
Whole image size: 3.8 MB (3932160 bytes)
Kernel size: 1.3 MB (1365645 bytes)
Rootfs size: 2.2 MB (2283546 bytes)
Kernel load address: 0x80060000
Kernel entry point: 0x80060000

Header CRC... skipped
Data CRC... skipped

Stopping network... OK!
Uncompressing Kernel... ERROR
## Error: LZMA error '1'!

## Error: failed to execute 'bootcmd'!
Starting web server for update...

Link down: eth0
Link down: eth1
Ethernet mode (duplex/speed): 1/100 Mbps
HTTP server is starting at IP: 192.168.1.1
HTTP server is ready!

Data will be downloaded at 0x80800000 in RAM
Upgrade type: firmware
Upload file size: 3670020 bytes
Loading: #######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
#######################################
####

HTTP upload is done! Upgrading...


****************************
* FIRMWARE UPGRADING *
* DO NOT POWER OFF DEVICE! *
****************************

Executing: erase 0x9F020000 +0x380004; cp.b 0x80800000 0x9F020000 0x380004

Erase FLASH from 0x9F020000 to 0x9F3AFFFF in bank #1
Erasing: #######################################
##################

Erased sectors: 57

Copying to FLASH...
Writing at address: 0x9F020000

Done!

HTTP ugrade is done! Rebooting...

Resetting the board...

***************************************
* U-Boot 1.1.4-7a540a78-clean *
* Build: 2018-02-23 *
***************************************

** Warning: bad env CRC, using default,
use 'saveenv' to save it in FLASH

BOARD: TP-Link TL-WR841N/D v8
SOC: AR9341 rev. 3
CPU: MIPS 74Kc
RAM: 32 MB DDR1 16-bit CL3-3-3-8
FLASH: 8 MB Winbond W25Q64
MAC: C0:4A:00:B8:27:8C
CLOCKS: CPU/RAM/AHB/SPI/REF
550/400/200/ 25/ 25 MHz

Hit any key to stop booting: 1 0

Booting image from 0x9F020000...

Vendor/image name: OpenWrt r7989-82fbd85747
Hardware ID: 0x9410005
Whole image size: 3.8 MB (3932160 bytes)
Kernel size: 1.3 MB (1365645 bytes)
Rootfs size: 2.2 MB (2283546 bytes)
Kernel load address: 0x80060000
Kernel entry point: 0x80060000

Header CRC... skipped
Data CRC... skipped

Stopping network... OK!
Uncompressing Kernel... OK!
Starting kernel...

[ 0.000000] Linux version 4.9.214 (buildbot@0d27b924961c) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7989-82fbd85747) ) #0 Thu Feb 27 21:25:59 2020
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
[ 0.000000] SoC: Atheros AR9341 rev 3
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 02000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x0000000000000000-0x0000000001ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x0000000000000000-0x0000000001ffffff]
[ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000001ffffff]
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 8128
[ 0.000000] Kernel command line: board=TL-WR941ND-v5 console=ttyS0,115200 rootfstype=squashfs noinitrd
[ 0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[ 0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 27604K/32768K available (3408K kernel code, 167K rwdata, 424K rodata, 216K init, 211K bss, 5164K reserved, 0K cma-reserved)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.000000] Clocks: CPU:550.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[ 0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6950037990 ns
[ 0.000011] sched_clock: 32 bits at 275MHz, resolution 3ns, wraps every 7809031678ns
[ 0.008887] Calibrating delay loop... 274.02 BogoMIPS (lpj=1370112)
[ 0.081897] pid_max: default: 32768 minimum: 301
[ 0.087262] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.094785] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.106054] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ 0.117274] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.125638] NET: Registered protocol family 16
[ 0.132455] MIPS: machine is TP-LINK TL-WR941N/ND v5
[ 0.628223] clocksource: Switched to clocksource MIPS
[ 0.635242] NET: Registered protocol family 2
[ 0.641306] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.649290] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.656516] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.663854] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.670540] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.677952] NET: Registered protocol family 1
[ 0.687265] Crashlog allocated RAM at address 0x1f00000
[ 0.694603] workingset: timestamp_bits=30 max_order=13 bucket_order=0
[ 0.709917] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.716544] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.738871] io scheduler noop registered
[ 0.743325] io scheduler deadline registered (default)
[ 0.749701] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.760078] console [ttyS0] disabled
[ 0.784259] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a 16550A
[ 0.794078] console [ttyS0] enabled
[ 0.794078] console [ttyS0] enabled
[ 0.801639] bootconsole [early0] disabled
[ 0.801639] bootconsole [early0] disabled
[ 0.817484] m25p80 spi0.0: found s25fl064k, expected m25p80
[ 0.835801] m25p80 spi0.0: s25fl064k (8192 Kbytes)
[ 0.841125] 5 tp-link partitions found on MTD device spi0.0
[ 0.846889] Creating 5 MTD partitions on "spi0.0":
[ 0.851879] 0x000000000000-0x000000020000 : "u-boot"
[ 0.859326] 0x000000020000-0x00000016d890 : "kernel"
[ 0.866830] 0x00000016d890-0x0000007f0000 : "rootfs"
[ 0.873879] mtd: device 2 (rootfs) set to be root filesystem
[ 0.879837] 1 squashfs-split partitions found on MTD device rootfs
[ 0.886235] 0x0000003a0000-0x0000007f0000 : "rootfs_data"
[ 0.894364] 0x0000007f0000-0x000000800000 : "art"
[ 0.901683] 0x000000020000-0x0000007f0000 : "firmware"
[ 0.910606] libphy: Fixed MDIO Bus: probed
[ 0.934834] libphy: ag71xx_mdio: probed
[ 1.570321] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:00 [uid=004dd042, driver=Generic PHY]
[ 1.580601] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[ 2.210111] ag71xx-mdio.1: Found an AR934X built-in switch
[ 2.262511] eth1: Atheros AG71xx at 0xba000000, irq 5, mode:GMII
[ 2.271452] NET: Registered protocol family 10
[ 2.281607] NET: Registered protocol family 17
[ 2.286263] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[ 2.299827] 8021q: 802.1Q VLAN Support v1.8
[ 2.306227] hctosys: unable to open rtc device (rtc0)
[ 2.317215] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 2.325968] Freeing unused kernel memory: 216K
[ 2.330605] This architecture does not have kernel memory protection.
[ 2.558267] random: fast init done
[ 3.067686] init: Console is alive
[ 3.071544] init: - watchdog -
[ 3.989076] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[ 4.050778] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[ 4.069290] init: - preinit -
[ 4.822146] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 4.853731] random: procd: uninitialized urandom read (4 bytes read)
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[ 8.110501] mount_root: jffs2 not ready yet, using temporary tmpfs overlay
[ 8.144739] urandom-seed: Seed file not found (/etc/urandom.seed)
[ 8.357165] procd: - early -
[ 8.361113] procd: - watchdog -
[ 9.002102] procd: - watchdog -
[ 9.005666] procd: - ubus -
[ 9.121022] random: ubusd: uninitialized urandom read (4 bytes read)
[ 9.180632] random: ubusd: uninitialized urandom read (4 bytes read)
[ 9.187769] random: ubusd: uninitialized urandom read (4 bytes read)
[ 9.195573] procd: - init -
Please press Enter to activate this console.
[ 9.557329] kmodloader: loading kernel modules from /etc/modules.d/*
[ 9.569059] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 9.587218] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
[ 9.595565] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
[ 9.605916] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 9.621037] nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
[ 9.689440] xt_time: kernel timezone is -0000
[ 9.754643] PPP generic driver version 2.4.2
[ 9.761908] NET: Registered protocol family 24
[ 9.810929] ath: phy0: Unable to initialize hardware; initialization status: -5
[ 9.818537] ath9k ar934x_wmac: failed to initialize device
[ 9.824248] ath9k: probe of ar934x_wmac failed with error -5
[ 9.831990] kmodloader: done loading kernel modules from /etc/modules.d/*
[ 11.282520] urandom_read: 5 callbacks suppressed
[ 11.282530] random: jshn: uninitialized urandom read (4 bytes read)
[ 28.159782] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[ 28.166912] jffs2_build_filesystem(): unlocking the mtd device... [ 28.212852] done.
[ 28.214862] jffs2_build_filesystem(): erasing all blocks after the end marker... [ 28.776348] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 28.812166] br-lan: port 1(eth1.1) entered blocking state
[ 28.817757] br-lan: port 1(eth1.1) entered disabled state
[ 28.823846] device eth1.1 entered promiscuous mode
[ 28.828851] device eth1 entered promiscuous mode
[ 28.889068] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 28.957110] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 30.410065] eth1: link up (1000Mbps/Full duplex)
[ 30.414882] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 30.457417] br-lan: port 1(eth1.1) entered blocking state
[ 30.463072] br-lan: port 1(eth1.1) entered forwarding state
[ 30.549137] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 46.561596] done.
[ 46.563638] jffs2: notice: (1106) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[ 116.838283] random: crng init done

Itt már bebootolt az OpenWRT, lehet menni a webfelületre, vagy SSH-ra, ahol látszik is a +4MB hely a /overlay-en :

root@t400:~$ ssh root@192.168.1.1


BusyBox v1.28.4 () built-in shell (ash)

_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
-----------------------------------------------------
OpenWrt 18.06.8, r7989-82fbd85747
-----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# passwd
Changing password for root
New password:
Retype password:
passwd: password for root changed by root
root@OpenWrt:~# df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 2.3M 2.3M 0 100% /rom
tmpfs 13.6M 68.0K 13.5M 0% /tmp
tmpfs 13.6M 44.0K 13.5M 0% /tmp/root
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mtdblock3 4.3M 292.0K 4.0M 7% /overlay
overlayfs:/overlay 4.3M 292.0K 4.0M 7% /
root@OpenWrt:~#

Azt hittem, itt készen is van :D

Azaz, a flasht visszaforrasztva a routerbe, nem bootolt. Kivettem, vissza drótra, úgy meg megy. WTF intensifies :D

Először az tűnt fel, hogy megy minden, de nincs wifi interfész? A webfelületen sem volt, még Wireless menüpont sem.
Kis keresgélés után kiderült, hogy az ath9k (az Atheros chipek Linux drivere) panaszkodik, hogy az ath9k-wmac nem találja a WIFI MAC címét. (A boot vége felé ott is az üzenet.)

Megpróbáltam többféle full dump-ot feltenni, 841 v8 oroszt pl (itt akad sokféle). amivel szintén nem volt wifi. (Azaz a menüben ott volt, de SSID-t nem szórt. Viszont az 535MHz-es procin úgy bootol, mint a szél.)

Kiderült, hogy a TP routereken (azaz gondolom az Atheros alapúakon) van egy ART nevezetű partíció (Atheros Radio Test). Ebben vannak a wifi adatai (is). Meg a wifi MAC címe. Ha az nincs, nincs interfész sem. Nekem meg nincs backupom. A flash upgrade-s leírásban meg mi van (amit el is felejtettem, mint könnyű módszer az ART feltöltésére) : "First go to http://192.168.1.1/art.html and send art.bin previously backed up"

Másik routerről elvileg másolható (hexeditorral ki lehet cserélni a címeket is), de nincs másik. Mármint, egy full dump-ból pl. ki lehet szedni (de hogy pontosan hogy fordulnak a címek, stb., azt én nem tudom, pláne semmi infó nincs, hogy mi hol van a bináris file-ban... azon kívül, ami a boot közben kiírt memóriatérkében van, persze, amit szintén nem tudok hova tenni).

Szerencsére van egy C program, ami kiszedi az ART routerből, vagy fw binárisból is.
Ezzel a fent említett oroszból sikerült kinyerni valamit, ami reméltem, hogy az ART :D

Mondjuk az lehet, mert azóta működik a wifi a routeren, hogy ezt a moddolt bootloaderrel feltettem rá :D

(Közben lett ART csomó routerhez : lista itt, a zip itt jön le.)

Került rá egy DD-WRT - OpenWRT már nem nagyon lesz ilyen 4MB/32MB eszközökre sajnos, a DD viszont még mindig karbantartott akár egy 741-esre is, tehát biztonságos lesz hosszabb távra is.

Aztán kiderült, hogy nincs WAN :D

Azaz 18.06 OpenWRT-vel működött, 10 ping átment rajta, aztán fél perc szünet, majd megint 10 ping... :D
Késleltetés normális (amikor van forgalom), dmesg-ben semmi. Többi verzióval a kapcsolat sem épült fel. :D

Mivel a DD is képes portáthelyezésre, gondoltam áthelyezem a WAN-t az egyik LAN portra. Ez a router elvileg olyasmire lenne majd használva, hogy nagyon leválasztott adjon a lakásban levő IoT eszközöknek (lesz majd wifis kazán, miegymás), erre elég is lesz, ha a wifi és a WAN működik.
A WAN áthelyezése nem sikerült, viszont :
- kiderült, hogy a DD átenged minden forgalmat Disabled-re tett WAN porttal
- a WAN port jó, mert a LAN -ba áthelyezve teljesen jól megy rajta a forgalom
- olyan, mintha nem lenne semmilyen route-olás a WAN és a többi között???? DHCP-n kap IP-t, de semmi egyéb...

Addig-addig nyomogattam, hogy sikerült a kannibalizált 1043v3 MAC-ét odaadni a WAN-nak,és egy ugyanolyan MAC-ű portot létrehozni a LAN-ban is. Így a LAN egyáltalán nem működik, de a WAN-on van kifele kapcsolat, routing is van, és megy a wifi is, ahogy a minimum elvárásaim között szerepelt.

Az egy gond az információhiány volt az egész során, még csak különösebb nehézség sem adódott. Amint megtudtam / leesett, hogy mi hogyan kellett volna csinálni, máris működött az adott dolog. Mondjuk a fenti leírás két napot ölel fel, de elsőre nem is ment rosszul.

Update : Sajnos a routert később kinyírtam, kiderült, hogy már korábban kezdhettek felszakadni a flash vezetőszálai (ezért nem működött, ha be volt forrasztva az IC), és sikerült egy későbbi flash csere folyamán teljesen felszaggatni :(

Hozzászólások

(#1) Agyturbina


Agyturbina
senior tag
LOGOUT blog (1)

Tudom l, hogy imádod sanyargatni magad, ezért megkérdezem: hány db routert kuldjek postán? ;]

Van 2db tökéletesen működő, ha jól sejtem az nem érdekel :DDD

,........A szükségletek lettek a célok, és a célok szükségletek lettek........, ,........A paradoxonban az a szép, hogy paradox módon nem szép.............,

(#2) hcl válasza Agyturbina (#1) üzenetére


hcl
félisten
LOGOUT blog

Jaja, csak hibás kell, de abból sem mind :)
Meg ahol te vagy, onnan inkább ne postázzál, mert belerokkannék a pk-ba :D

Veszek _hibás_ LCD monitort,fényképezőgépet, objektívet, routert ---- Mutogatni való hater díszpinty

(#3) sonar


sonar
addikt

"Mint itt! " -nél nem müxik a link (feltéve ha akartál oda tenni)

A tudást mástól kapjuk, a siker a mi tehetségünk - Remember: Your life – Your choices!

(#4) hcl válasza sonar (#3) üzenetére


hcl
félisten
LOGOUT blog

Köszi! Javítottam. :R

Veszek _hibás_ LCD monitort,fényképezőgépet, objektívet, routert ---- Mutogatni való hater díszpinty

(#5) Blasius0704


Blasius0704
tag

Tényleg nem akarok a helyihülye lenni, de ezek ilyen párezer-tizezer forint értékű cuccok, kiszámoltad már valaha hogy a befektetett idő-energia megtérülés mellet mikor éri meg megcsinálnod őket? Vagy én vagyok nagyon közgazdász?

(#6) hcl válasza Blasius0704 (#5) üzenetére


hcl
félisten
LOGOUT blog

Te vagy.
Mi van, ha azt mondom, nem csak pénzben térülhet meg valami?

(BTW de, még azt is ki lehet, hogy ha az a 941 pl. ingyen volt, mert hibás (valami minimális pénzbe persze került), és én konkrétan pénzt nem költöttem el rá, akkor ha nem kell vennem egy 3000Ft-os routert, akkor sem jártam rosszul, ha használatba veszem. Nézhetek persze helyette filmet is, de akkor még mindig routert kell vennem, ha kell 1 router :D . Nem mellesleg, ha már, akkor a rejtvényújságért is fizet az ember, de abból sem épül a tudásod. )

Azt már nem is mondom, hogy az ilyenekből megszerezhető tudás mennyit tud érni konkrét fizetésben.

[ Szerkesztve ]

Veszek _hibás_ LCD monitort,fényképezőgépet, objektívet, routert ---- Mutogatni való hater díszpinty

(#7) nullpoint


nullpoint
senior tag

Legközelebb ha valakinek tönkremegy a fűtőszál a mosógépben, és nincs kedve/ideje szétszedni,megjavítani, csak küldje el hcl-nek postán vagy futárral. Alkatrészt sem kell küldeni mellé, majd megoldja valahogy.

;] ;] ;] ;] ;] ;] ;]

(#8) hcl válasza nullpoint (#7) üzenetére


hcl
félisten
LOGOUT blog

A frászt, akkora döggel szórakozzon valami erőművész... :D

Veszek _hibás_ LCD monitort,fényképezőgépet, objektívet, routert ---- Mutogatni való hater díszpinty

(#9) nullpoint válasza hcl (#8) üzenetére


nullpoint
senior tag

Jajj má' most mit izélsz. Nem kell emelgetni. Szépen raklapra lerakod, ugyanúgy körbe lehet járni mint egy routert. :K :P

(#10) hcl válasza nullpoint (#9) üzenetére


hcl
félisten
LOGOUT blog

Majd befolyok alá, ja. Akkor legalább lesz befolyásom :D

Veszek _hibás_ LCD monitort,fényképezőgépet, objektívet, routert ---- Mutogatni való hater díszpinty

További hozzászólások megtekintése...
Copyright © 2000-2021 PROHARDVER Informatikai Kft.