2024. április 18., csütörtök

Gyorskeresés

Aki ért a DOS-hoz és az SCSI-hez,Gyüjjön! Alakulgat a dolog!

Írta: |

[ ÚJ BEJEGYZÉS ]

Srácok segítsetek már, mert megbolondulok :W
osztrakjsat cimborám aszondta, hogy szeretem saját magam szop... szívatni, és sajna tényleg így van, mert olyan agyament dolgokat akarok megvalósítani hogy a legelvakultabb PC fanatikus haja is égnek áll :W
Most azt találtam ki hogy egy 486-oson (Socket4-s Pentiumon?) Windows 3.11 alatt cd-t akarok írni SCSI CD íróval!
A gondom az, hogy egyszerűen már ott elakadok, hogy nem látja az SCSI olvasót (vezérlőt?) a DOS!
Kezdjük szépen az elejétől!
2 gépbe is próbáltam 3 SCSI kártyát is! a 486-osba és a Pentiumba is mindíg ugyanaz a hiba, illetve ahol el akadok! A problémám több PH-s penge cimborámnak felvetettem, de csak fejvakarás ment részükről is! De reménykedem, hogy azért van ittennék valaki aki vágja a borsót!
Na jó sok a rizsa kezdjünk bele!
Van egy (kettő) adaptec 1542-es SCSI kártyám erre 50pines tikbéllel egy TEAC CD olvasó van rákötve!
Bootolás előtt az SCSI vezérlő FELISMERI AZ OPTIKÁT gyün a DOS...
ahhoz menjen a cucc, a vezérlőt DOS alá (és Win3.11 alá is) fel kell telepíteni! az adaptec HIVATALOS HONLAPJÁRÓL leszedtem a drivert, majd követtem az instrukciókat!
ez lesz az
szépen elkezdtem ovlasni a readme-t mit és hogyan a data.hu-ra feltöltöttem ha érzel egy kis lelkierőt léci fusd át te is, innen lehet letölteni

Szóval, Adaptec 1542-es kártyához az aspi4dos.sys és az aspicd.sys file-t kell beletolni a config.sys-be, megtörtént!
az autoexec.bat-ba pontosan azt másoltam bele amit a readme-be írt hogy az kell neki...
Mikor elkezd bootolni a DOS, szépen fel ismeri, hogy ottan van valami kártya féleség:

De nézzétek csak! Bal felső sarokba: Host Adapter: 0

Majd lentebb írja hogy CD ROM Driver Not loaded mert ugyebár not valid host adapter... meg hogy az aspi4dos.sys-t sem tudja betölteni
DE MIÉÉÉÉÉÉÉRTTTT? :O :O :O :O
Toltam bele egy nagyon hasonló, hangyányit régebbi szintén ugyaniylen típusú vezérlőt! ugyanez volt..
oké mondom akkor kap egy PCI-os Adaptec AHA2940UW2-t
a readme-be írja hogy ehhez ugye az aspi8u2.sys file kell, így hát kicseréltem arra...
oké kártya be majd induláskor ugyanez votl a szitu! írta hogy ott ottann van a kártya cask hogy HOST device 0 :O :W :W
ezt megjátszottam a 486-osba, és a Pentiumba is, mind a 3 kártyát végig próbáltam, úgy is hogy az optika nem volt rákötve a kártyára, a két 1542-nél próbáltam úgy hogy a kártya plug and play legyen illetve hogy én állítsan me az IO címet.... úgyis mindig ugyanez.. a PCI-os kártyánál természetesen már nem kell semmit se jumperolni tehát szerintem a jumperolással sincs gond de akkor miért nem megy? :O

Van videó is mostmár!

Nahh itten van a videó lessétek meg gyorsan csak :))

A fontosabb infókat akkor kifényképeztem a job minőség érdekében, lássátok:

Közbe ennyrie jutottam:

azaz látja működik meg minden! de egyenlőre úgy hogy flopy-ról bootolva... Most az a kérdés, hogy mit kéne hekkelni hogy menjen HDD-ről indítva a gépet? csak mert flopy-ról is úgy indítottam a rendszert mint amikor hdd-ről próbáltam, azaz a szükséges 2 sor ment a config.sys-be illetve az autoexec.bat-ba is és szépen jó is lett.. ugyanezt lőttem be a HDD eseténél is de ott meg ugye nem volt jó...

Hozzászólások

(#1) bacsis


bacsis
Közösségépítő

Jó hosszú lett de azért HELP :))

(#2) danih


danih
addikt

Szerintem nem baj, hogy a "Host Adapter #: 0". Ez nem azt jelenti, hogy not found. IDE-nél is van pl. 0:0 hely. Én nem itt kezdeném a hibakeresést. Próbáltál más eszközt az adaptec vezérlőre tenni? Ha látná ilyesmi jönne:
Host Adapter #0 - SCSI ID 0 - LUN 0: (CD-ROM AKÁRMI)

(#3) Samus


Samus
addikt

UP, ennyire nem értek hozzá, de valami a driverrel van, mert ugye azzal indul, hogy a telepítése sikertelen (ASPI4DOS.SIS failed), ez után nem meglepő, hogy nincs hozzá driver, és emiatt pedig a következő hiba, hogy nincs kártya sem (mert nem látja, mert a driver nem települt fel)...

[ Szerkesztve ]

'' Az élet egyszerű. Döntéseket hozol és nem nézel vissza.'' // Tomorrow's just your future yesterday!

(#4) bacsis válasza danih (#2) üzenetére


bacsis
Közösségépítő

uhh, kezdésnek nem rossz, megpróbálom másik drive-al, bár a kérdés felmerül hogy akkor az SCSI bios miért ismeri fel ha esetleg télleg az optika a bűnös? :U

(#5) Raucher válasza bacsis (#4) üzenetére


Raucher
tag

Az SCSI esetében le kellett zárni a buszt, ha már nem volt több egység rajta.

Ez rendben van?

Tisztán emlékszem minden előző életemre, ezért nem hiszek a reinkarnációban!

(#6) moha21


moha21
addikt

Na szóval MSCDEX.exe az minden meghajtóhoz jó volt DOS alatt, azzal nem sok probléma lehet max. annyi ha elfogy a 640k, de akkor ugye el sem indul ( LH parancs megoldás ).

A SCSI kártyáról kellene bővebb információ. Az kizárt, hogy mindhárom kártya rossz lenne.

Config.sys-ben kellene jól beállítani a cuccot, de ez ahány eszköz annyiféle megszakítás és egyéb paraméter tud lenni.

"DEVICE=A:\HIMEM.SYS
DEVICE=A:\EMM386.EXE
DEVICE=A:\MTMCDAI.SYS /D:MTMIDE0 " EZ valami mitsumi CD olvasóhoz volt. D meghajtó lesz belőle.

CONFIG.SYS: DEVICEHIGH=C:\SCSI\ASPI2IBM.SYS /D
DEVICEHIGH=C:\SCSI\ASPICD.SYS /D:ASPICD0
LASTDRIVE=Z
AUTOEXEC.BAT: LOADHIGH C:\SCSI\MSCDEX.EXE /D:ASPICD0

valami ilyesmi kellene. A lényeg, hogy előbb a config .sys-ben is a kártya driver legyen előbb és csak utána a CD.

Nem az az igazi férfi aki minden nőt meghódít, hanem aki ismeri a nagyfeszültségű földkábelek szigetelésének technikáját.

(#7) bacsis válasza Raucher (#5) üzenetére


bacsis
Közösségépítő

bányászok optikát el ne menjetek sehova minnyá gyüvök :D

(#8) bacsis


bacsis
Közösségépítő

másik optikával másik kábellel próbáltam ez egy win95ös 486osban volt s működött!
most is ugyanezt a hibát kaptam...
a kábelen van természetesen termináló :U
a kártya egész pontosan egy AHA-1540/42CP van nekijje BIOS is...
moha21 Minnyá körbe nézek a config.sys-be hátha a te leírtakból kijön valami okosság :B

[ Szerkesztve ]

(#9) Syl


Syl
nagyúr

Az Adaptec kártyáknak nem hogy van saját BIOS-uk? - szerk. látom időközben észrevetted.

[ Szerkesztve ]

Never let your sense of morals prevent you from doing what's right.

(#10) bacsis


bacsis
Közösségépítő

nahhh a config.sys-be van betöltve
(rövidítek):
Himem.sys 640k fölötti memória használata
és akkor az optikához:
aspi4dos.sys /D
AspiCD.sys /D:ASPICD0

autoexecbe meg ez:
....Mscdex,exe /D:Aspicd0 /M:12

Amúgy az IDE-s drive-ot nagyon szépen felismeri a gép, természetesen nem ezekkel az illesztőkkel :D az a "banana-s driverrel megy" tehát az mscdex-el nincs gond :U

További hozzászólások megtekintése...
Copyright © 2000-2024 PROHARDVER Informatikai Kft.